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Getting started  

Microsoft Office Button 
The Microsoft Office Button performs many of the functions that were located in the File 
menu of older versions of Access.  This button allows you to create a new database, 
open an existing database, save and save as, print, send, or close. 

 

The Ribbon 
The ribbon is the panel at the top portion of the document   It has four tabs:  Home, 
Create, External Data, and Database Tools.  Each tab is divided into groups.  The groups 
are logical collections of features designed to perform function that you will utilize in 
developing or editing your Access database.   

 

 
 
Commonly utilized features are displayed on the Ribbon.  To view additional features 
within each group, click the arrow at the bottom right corner of each group. 
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Home:  Views, Clipboard, Fonts, Rich Text, Records, Sort & Filter, Find 
Create: Tables, Forms, Reports, Other 
External Data: Import, Export, Collect Data, SharePoint Lists 
Database Tools: Macro, Show/Hide, Analyze, Move Data, Database Tools 

Quick Access Toolbar 
The quick access toolbar is a customizable toolbar that contains commands that you may 
want to use.  You can place the quick access toolbar above or below the ribbon.  To 
change the location of the quick access toolbar, click on the error at the end of the 
toolbar and click Show Below the Ribbon. 
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Navigation Pane 
The Navigation Pane displays database objects such as tables, forms, queries, and 
reports. 

 

Tabbed Document Window Viewing 
Tabbed document viewing opens tables, forms, queries and reports in the same 
window.  Click the tabs to switch between windows. 
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Table relationships  

Table relationships are the associations of data between tables.  By defining table 
relationships, you can pull records from related tables based on matching fields.   

 

One-to-One Relationship 
A one-to-one relationship is between two tables where the primary key in one table and 
the foreign key in another table are the same.  For each record in the first table, there is a 
single matching record in the second table.   
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One-to-Many Relationship 
A one-to-many relationship occurs between two tables where the primary key in one 
table can be duplicated many times in another table 

 

Creating Table Relationships 
To create relationships between tables: 

 Click the Database Tools tab on the Ribbon 
 Click the Relationships button  

 

 Click on the Design tab 
 Click Show Table 
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Select the desired tables 

 Click Add 
 Click Close 

 

 Click the field you wish to create a relationship from 
 Drag it to the matching field in the other table 
 Click Create 
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Print a Table Relationship 

 Click the Database Tools tab 
 Click the Relationships Button 
 Click the Relationship Report Button on the Design tab 

  

 Click the Print button 
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Customize Access 

Access 2007 offers a wide range of customizable options that allow you to make Access 
work the best for you.  To access these customizable options: 

 Click the Office Button  
 Click Access Options  
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Popular 
These features allow you to personalize your work environment with the use of 
ScreenTips, the location and file format of the databases, and the username. 
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Current Database 
This feature allows you to set options for the Application, Navigation, Ribbon and 
Toolbars, AutoCorrect, and Filters. 
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Datasheet 
This features allows you to personalize options in the way the datasheet looks, including 
default colors, gridlines and cell effect, and font. 
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Object Designers 
This feature allows you to customize the options for creating and modifying database 
objects in Access including Table Design, Query Design, Forms/Reports, and Error 
Checking. 
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Proofing 
This features allows you to change how Access automatically correct and formats the 
contents of the database and how it indicates errors. 
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Advanced 
This feature allows for advanced customization of Access including, Editing, Display, 
Printing, and other advanced options. 

 

Customize 
Customize allows you to add features to the Quick Access Toolbar.  If there are tools that 
you are utilizing frequently, you may want to add these to the Quick Access Toolbar. 
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Managing data  

Add Records to a Table 
To add a new record to a table: 

 Open the table in Datasheet View 
 Click the New Cell 
 Type in your new record 

 

Find and Replace 
To find data: 

 Click the Find button on the Home tab 
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To find and replace data: 

 Click the Replace button on the Home tab 

 

When you are searching for data for a find, replace or go to, you have several options in 
the Find Dialog Box.  These options are: 

Find What Text Box Type the text you wish to 
find 

Link in Drop Drop-Down 
List 

Use the drop-down list to 
specify a table or a column 
to search 

Match Drop-Down List Use the drop-down list to 
narrow down the search to 
a field or the beginning of a 
field 

Search Drop-Down List Use this drop-down to 
specify the direction to 
search. 

Match Case Check Box Use this check box to 
specify whether to search 
by the same upper and 
lower case letters. 
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Totals 
The totals button provides you the opportunity to add a totals row to your database.  The 
total can be the sum, average, a count, minimum, maximum, standard deviation, or the 
variance.  To set up a totals row: 

 Click the Totals button on the Home tab 

 

 Click the down arrow of the cell where you want the totals 
 Click the appropriate choice 
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Sort Records 
You can sort records in a datasheet by a single column or by two adjacent columns.  To 
sort records by a single column: 

 Select the field you wish to sort 
 Click the Sort Ascending or Sort Descending button 

 

To sort two columns: 

 Move the columns to they are adjacent to each other 
 Select the desired columns for sorting by holding the shift key and clicking the 

columns 
 Click the Sort Ascending or Sort Descending button 
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To clear the sort: 

 Click the Clear Sort button 

 

Filter 
You can filter records to include only records that you want to display.  To filter by a 
column: 

 Open the database in Datasheet View 
 Click the down arrow in the field label 
 Choose the appropriate filter criteria 
 Click OK 
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To remove a filter: 

 Click the filter button on the field label 
 Click Clear Filter  
 Click OK 

 



 

22 

 

Database terms  

Table 
A table is a collection of information arranged in rows and columns.  Information about an 
item is displayed in a row.  Columns contain the same type of information for each 
item.  The table has a header row that tells you what data is contained in the columns. 

 

To view data in a table: 

 Click the arrow to open the navigation pane 
 Double-click on the table name to open the table 

 

Query 
Queries select records from one or more tables in a database so they can be viewed, 
analyzed, and sorted on a common datasheet. A query can also perform calculations and 
display the results.   

The resulting collection of records, called a dynaset (short for dynamic subset), is saved 
as a database object and can therefore be easily used in the future. The query will be 
updated whenever the original tables are updated.  
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Types of queries are; 

 select queries that extract data from tables based on specified values,  
 find duplicate queries that display records with duplicate values for one or more of 

the specified fields, and  
 find unmatched queries display records from one table that do not have 

corresponding values in a second table. 

To run a query: 

 Click the arrow to open the navigation pane 
 Double-click on the query name 

 

Recordset 
A recordset is a table that displays groups of records from a base table or as a query 
result.   

Form 
A form is a graphical interface that is used to display and edit data.  Forms can be 
developed from a table or a query.  Forms can include calculations, graphics and objects. 

To view data using a form: 

 Click the arrow to open the navigation pane 
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 Double-click on the form name 

 

Report 
A report is an output of data arranged in the order you specify.  Reports can perform 
calculations and display the results.  Reports can be used to print data. 
To view data using a form: 

 Click the arrow to open the navigation pane 
 Double-click on the report name 

 

Querying a database  

A query allows you to select and filter data from multiple tables.  Queries can be saved 
and utilized as often as you need them. 
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Query Wizard 
The Query Wizard walks you through the steps to set up a query.  To run a query using 
the query wizard: 

 Click the Create tab 
 Click the Query Wizard button 

 

 Choose the type of query you wish to run 
 Click OK 

 

 Choose the fields you wish to include from each table 
 To select fields from different tables, click the Tables/Queries down arrow 
 Click Next 
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Insert pic of query wizard 

 Type in a title for the query 
 Click Finish 
 The query will display  
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To switch between tables and queries: 

 Open the Navigation Pane 
 Double click the name of the table or query you wish to view 
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Query Design Feature 
You can also design a query with the  Query Design Button.  To design a query using the 
Query Design Button: 

 Click the Query Design Button on the Create tab 

 

 Select the tables that you would like to query 
 Click Add 

 

 Double click the name of the field you would like to query 
 Repeat this process for as many fields as you would like in the query 
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 Click Run 

 

Query Criteria 
Query criteria are search conditions used in a query to retrieve specific data.  You can 
set query criteria to be a specific number or data set, or you can set the criteria to be a 
range of data. 

“value” Will only display items that 
are that exact value 
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(replace the word value 
with what you want to 
search by) 

= Is equal to 
<  Less than 
<= Less than or equal to 
>  Greater than 
>= Greater than or equal to 
<>  Not equal to 
Between  X  And Y Within a range (replace X 

& Y with values) 
Is Null Null values 
And True only if both 

conditions exist  
Or True if either condition 

exists 
Not True if the single instance 

is not true 

To specify search criteria: 

 Click the query that you wish to add conditions 
 Type in the appropriate query criteria in the Criteria Box 

 

Calculating  fields  

A calculated field is a field that gets its information from the calculations performed on 
other fields.  You can build calculated fields in the Query screen by using the addition (+), 
subtraction (-), multiplication (*) and division (/) operators.   

Expressions 
Expressions a combination of functions, field names, numbers, text, and the operators 
listed above.   

To build an expression to create a calculated field: 

 Open an existing query or start a new query 
 Click on the View Button 
 Click on Design View 
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 In the Query Pane, right-click on the field where you would like to create the 
calculation 

 Click Build 

 

 Choose the tables that you wish to build the calculation from 
 Double-click the field that you want to include in the calculation 
 Click the operator that you wish to include in the calculation 
 Click the second field you wish to include in the calculation 
 Click OK 
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 Click Run 

 

Zoom 
The Zoom Dialog Box allows you to view an entire expression at one time.  To view the 
Zoom Dialog Box: 

 In Design View, right click on the field you want to display 
 Click Zoom 
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Create a New Database 

You can create a new database from scratch or you can create a database from the 
database wizard. 

New Database 
To create a new database from scratch: 

 Click the Microsoft  Office Button 
 Click New 
 Click the New Blank Database icon 

 

 Type in a name for the database 
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 Click Create 

 

Database Templates 
To create a new database from the database templates: 

 Click the Microsoft Office Button 
 Click New 
 Choose the type of database you wish to create 

 

 Type in the name for the database 
 Click Create 
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Designing forms  

Forms allow you to control the look and feel of the screen for the input of data and the 
reports generated.   

Form Views 
There are three ways to view forms in Access: 

 
Design View  

Allows you to design a 
form that includes a 
header, a footer, and 
details in the form.  You 
can also add images and 
control which fields 
appear on the form. 

Form View This is a dynamic page 
which allows the user to 
enter and edit data or 
navigate through data in a 
field.   

Layout View This view allows you to 
design the form and 
manipulate data. 

  

Create a Form 
You can create a form from a table or a query.  To create a form: 

 Click the Create tab 
 Click the Form Design button 
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 Click the Format tab  
 Click the Add Existing Fields Button  
 In the Field List box on the right, click and drag the fields you would like on the 

form 

 

 To change the colors and fonts, click the Property Sheet button on the Arrange 
tab  
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Insert pic of property sheet button 

 Choose the Section you wish to modify  
 Choose the properties you wish to modify 

 

To preview the form: 

 Click the Views button on the Home tab  
 Click the Form View button 
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Form Wizard 
You can create forms with the help of the Form Wizard.  To use the form wizard: 

 On the create tab, click the More Forms down arrow 
 Click Form Wizard 

 

 Choose the Tables/Queries that you wish to have on the form 
 Choose the fields you wish to have on the forms 
 Click Next 
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 Chose the layout for the form 
 Click Next 

 

 Choose a style 
 Click Next 
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 Create a title for the form 
 Choose whether you want to open the form to view it or modify the form’s design 
 Click Finish 
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Create a Table 

Table Views 
There are two ways to view a table in Access to add data to the table:  Design View and 
Datasheet View.   

In Design View you can view all the fields with the data types and descriptions.  The 
records of information that has been added to the database is not viewable.   

 

To go to Design View: 

 Click the down arrow on the View button 
 Click Design View 
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In Datasheet View you can display the records in a table, where one row is one 
record.  The column headers are the fields you have defined for the database.   

 

To go to Datasheet View: 

 Click the down arrow on the View button 
 Click Datasheet View 
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Adding  New Fields 
There are many ways to enter new fields into a database.  New fields can be added in 
the Datasheet View or in the Design View. 

There are two ways to add a new field in Datasheet View:  Add A New Field or the New 
Field Button.   

To add a New Field within the Datasheet: 

 Click the Add New Field column 

 

To add a new field by using the New Field Button 

 Click the Datasheet tab on the Ribbon 
 Click the New Field Button 
 Choose the type of field you wish to add from the Field Templates window 



 

44 

 

 

To add a new field in Design View: 

 Click the Design View button 
 Click on the next available field 
 Type in the Name of the field 

 

Data Types 
There are many types a data that a field can be predefined to hold.  When you create a 
new field in a database you should closely match the data type to what will be entered 
into the field. 

Text Text, number, or a combination up to 255 
characters 



 

45 

 

Memo Similar to the text field, can contain text, 
numbers, or a combination up to 2 GB of 
data. 

Number Numbers up to 16 bytes of data 
Date/Time Date and Time information 
Currency Currency up to 8 bytes and precise to 4 

decimal places 
AutoNumber Access creates a unique number for each 

new record.  This is often the primary key 
for the table 

Yes/No Yes and No, stored as -1 for yes and 0 for 
no  

OLE Object Images, documents, graphs up to 2 GB 
Hyperlink Web addresses 
Attachment Attachments such as images, 

spreadsheets, documents, and charts. 

  

Editing Data Types in Fields 
When creating tables, you should define the data types of the tables to most closely 
match the type of data that will be entered in the field. 

To edit the Data Type in Datasheet View: 

 Click the field you wish to define 
 Click the Datasheet tab on the Ribbon 
 Click the down arrow next to Data Type 
 Choose the type of data that will be entered into the field 

 

To edit the format of the data: 

 Click the field you wish to define 
 Click the Datasheet tab on the Ribbon 
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 Click the down arrow next to Format 

 

To edit the Data Type in the Design View: 

 Click Design View 
 Click the field name you wish to define or create a new field 
 Click the Data Type 
 Choose the appropriate Data Type 
 Format the field in the Field Properties Dialog box 
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Generating Reports 

Reports are a means to view and analyze large amounts of data.    You can use the 
Report Wizard or create a custom report that meets your specific needs. 

Report Views 
Reports can be displayed in four views: 

 
Design View  

This view provides you with the 
structure of your report.  You 
can add, modify or delete 
components of the report but 
you cannot manipulate the 
data in the tables associated 
with the report. 

Report View This view allows you to view 
the data from the table but not 
to change any layout of the 
report. 
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Layout View This view allows you to see 
data from the table and add, 
modify, and delete 
components of the report. 

Print Preview This view allows you to see 
what your report will look like 
when it is printed. 

To change report views: 

 Click the View button on the Home tab 

 

Create a  Report 
To create a blank report: 

 Click the Blank Report button on the Create tab 

 

 Click the Add Existing Fields button  
 From the field list, Click and drag the fields to the report 
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Report Wizard 
To create a report using the report wizard: 

 On the Create tab, click the Report Wizard button 

 

 Choose the Tables/Queries that you wish to have on the form 
 Choose the fields you wish to have on the forms 
 Click Next 
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 Choose the sort order for your report 

 

 Chose the layout for the form 
 Click Next 
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 Choose a style 
 Click Next 

 

 Create a title for the form 
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 Choose whether you want to open the form to view it or modify the form’s design 
 Click Finish 

 

Custom Calculated Fields 
You can create reports that include calculated fields.  These reports will display 
information that you wish to report with an arithmetic calculation. To add a custom 
calculated field to a report: 

 Open the Report that you wish to add to  
 Click the View button 
 Click Design View 
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 Click the Design tab 
 Click the Text Box button 

 

 Click the section on the report where you would like to locate the textbox 
 Click the Property Sheet Pane 
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 Click the Data tab 
 Click the three dots next to Control Source 
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 Insert the fields you wish to include in the calculation and the mathematical 
operations. 

 Click OK 
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Manage Tables 

Delete a Table 
To delete a table: 

 Open the desired database by clicking the Microsoft Office Button and clicking 
Open 

 Right click on a table and choose Delete 
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Rename a Table 
To rename a table: 

 Open the desired database by clicking the Microsoft Office Button and clicking 
Open 

 Right click on a table and choose Rename 
 Type in the new name 
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Add a Description to a Table 
To add a description to a table 

 Open the desired database by clicking the Microsoft Office Button and clicking 
Open 

 Right click on a table and choose Table Properties 
 Click the Description text box 
 Type in the description 
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Print a Report 

After you have generated a report, you can print the report.  To print the report: 

Print a Report 
To print a report: 

 Select the report you wish to print 
 Right-click on the Report Name  
 Click Print Preview  
 Choose the appropriate layout, margins, and paper size in the Page Layout group 

 

 

 Click Print 
 Click OK 
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Keys 

Primary Key 
The primary key is a unique identifier for a record.  The primary key cannot be the same 
for two records.  This field can never be blank. 
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Composite Key 
A composite key is a primary key that is comprised of two or more fields.  It can also be 
called a compound or concatenated key.   

Foreign Key 
A foreign key is a field or combination of fields that are related to the primary key of 
another table. 

 
 

 

 

 


